import re
regex = re.compile(r"(\d+) +(@\S+@)? *(\S+) +(.*)", flags=re.MULTILINE)
test_str = ("0 HEAD\n"
"1 CHAR UTF-8\n"
"1 SOUR Ancestry.com Family Trees\n"
"2 VERS (2010.3)\n"
"2 NAME Ancestry.com Family Trees\n"
"2 CORP Ancestry.com\n"
"1 GEDC\n"
"2 VERS 5.5\n"
"2 FORM LINEAGE-LINKED\n"
"0 @P6@ INDI \n"
"1 BIRT ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")