re = /(\d+) +(@\S+@)? *(\S+) +(.*)/m
str = '0 HEAD
1 CHAR UTF-8
1 SOUR Ancestry.com Family Trees
2 VERS (2010.3)
2 NAME Ancestry.com Family Trees
2 CORP Ancestry.com
1 GEDC
2 VERS 5.5
2 FORM LINEAGE-LINKED
0 @P6@ INDI
1 BIRT '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end