const regex = /Modules\s=\s"[^"]*\b40\b[^"]*"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Modules\\s=\\s"[^"]*\\b40\\b[^"]*"', 'g')
const str = `Modules = "3,15,15,15,15,15,15,15,15". Modules = "3,40,40,40" Modules = "3,40,40,40,40,40,40" `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}