// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"Modules\s=\s"[^"]*\b40\b[^"]*""#).unwrap();
let string = "Modules = \"3,15,15,15,15,15,15,15,15\". Modules = \"3,40,40,40\" Modules = \"3,40,40,40,40,40,40\" ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}