$re = '/Modules\s=\s"[^"]*\b40\b[^"]*"/';
$str = 'Modules = "3,15,15,15,15,15,15,15,15". Modules = "3,40,40,40" Modules = "3,40,40,40,40,40,40" ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);