re = /Modules\s=\s"[^"]*\b40\b[^"]*"/
str = 'Modules = "3,15,15,15,15,15,15,15,15". Modules = "3,40,40,40" Modules = "3,40,40,40,40,40,40" '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end