#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:40\d[0-5]|[1-3]\d{3}|[1-9]\d?\d?|0),?\b){4}$"
Local $sString = "0,1,3,9" & @CRLF & _
"12,99,999,4095" & @CRLF & _
"99,999,3999,4095" & @CRLF & _
"1200,2500,2000,90" & @CRLF & _
"" & @CRLF & _
"01,002,003,0" & @CRLF & _
"99,999,3999,4096" & @CRLF & _
"1200,2500,6500,90" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")