import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:40\\d[0-5]|[1-3]\\d{3}|[1-9]\\d?\\d?|0),?\\b){4}$";
final String string = "0,1,3,9\n"
+ "12,99,999,4095\n"
+ "99,999,3999,4095\n"
+ "1200,2500,2000,90\n\n"
+ "01,002,003,0\n"
+ "99,999,3999,4096\n"
+ "1200,2500,6500,90\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}