$re = '/^(?:(?:40\d[0-5]|[1-3]\d{3}|[1-9]\d?\d?|0),?\b){4}$/m';
$str = '0,1,3,9
12,99,999,4095
99,999,3999,4095
1200,2500,2000,90
01,002,003,0
99,999,3999,4096
1200,2500,6500,90
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);