using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@(?=([\w.@-]*\w))\1(?!\[\d+\])";
string input = @"Hello @kevin
Hello @kevin.
Hello @kevin[1].
Hello @kev._in[1].";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}