const regex = new RegExp('@(?=([\\w.@-]*\\w))\\1(?!\\[\\d+\\])', 'gm')
const str = `Hello @kevin
Hello @kevin.
Hello @kevin[1].
Hello @kev._in[1].`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}