$re = '/@(?=([\w.@-]*\w))\1(?!\[\d+\])/m';
$str = 'Hello @kevin
Hello @kevin.
Hello @kevin[1].
Hello @kev._in[1].';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);