re = /@(?=([\w.@-]*\w))\1(?!\[\d+\])/m
str = 'Hello @kevin
Hello @kevin.
Hello @kevin[1].
Hello @kev._in[1].'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end