using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^~`""=!@#$%\^&\*\(\)\+=\\\|\}\]\{\['":?.></]+$";
string input = @"سلام این سرزیمین ایران است anbsasd*(&*&(*HBJKKJhسیشسیبسیب۱۲۳۲۳123123-,";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}