$re = '/[^~`"=!@#$%\^&\*\(\)\+=\\\\\|\}\]\{\[\'":?.></]+$/m';
$str = 'سلام این سرزیمین ایران است anbsasd*(&*&(*HBJKKJhسیشسیبسیب۱۲۳۲۳123123-,';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);