package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^~`"=!@#$%\^&\*\(\)\+=\\\|\}\]\{\['":?.></]+$`)
var str = `سلام این سرزیمین ایران است anbsasd*(&*&(*HBJKKJhسیشسیبسیب۱۲۳۲۳123123-,`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}