re = /[^~`"=!@#$%\^&\*\(\)\+=\\\|\}\]\{\['":?.><\/]+$/m
str = 'سلام این سرزیمین ایران است anbsasd*(&*&(*HBJKKJhسیشسیبسیب۱۲۳۲۳123123-,'
# Print the match result
str.match(re) do |match|
puts match.to_s
end