package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(([\d]+):)?([\d]+):([\d]+):(.{0,20}): (.*)$`)
var str = `
// TeamID, ClientID, Mode, PlayerName, Text
//%d:%d:%d:%s: %s - team chat
0:63:1:Günther: hey popelz
// ClientID, Mode, PlayerName, Text
// %d:%d:%s: %s - global chat - previous & current format
63:1:Günther: hey popelz
// this parsing can be split in two regular expressons if needed.
// Group 1 can be ignored
// Group 2 contains the teamID (I guess it's None type when there is no teamID
// Group 3: CliendID
// Group 4: Mode
// Group 5: Nickname
// Group 6: Text message`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}