# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(([\d]+):)?([\d]+):([\d]+):(.{0,20}): (.*)$"
test_str = ("\n"
"// TeamID, ClientID, Mode, PlayerName, Text\n"
"//%d:%d:%d:%s: %s - team chat\n\n"
"0:63:1:Günther: hey popelz\n\n"
"// ClientID, Mode, PlayerName, Text\n"
"// %d:%d:%s: %s - global chat - previous & current format\n\n"
"63:1:Günther: hey popelz\n\n\n"
"// this parsing can be split in two regular expressons if needed.\n\n"
"// Group 1 can be ignored\n"
"// Group 2 contains the teamID (I guess it's None type when there is no teamID\n"
"// Group 3: CliendID\n"
"// Group 4: Mode\n"
"// Group 5: Nickname\n"
"// Group 6: Text message")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.