const regex = new RegExp('(([\\d]+):)?([\\d]+):([\\d]+):(.{0,20}): (.*)$', 'gm')
const str = `
// TeamID, ClientID, Mode, PlayerName, Text
//%d:%d:%d:%s: %s - team chat
0:63:1:Günther: hey popelz
// ClientID, Mode, PlayerName, Text
// %d:%d:%s: %s - global chat - previous & current format
63:1:Günther: hey popelz
// this parsing can be split in two regular expressons if needed.
// Group 1 can be ignored
// Group 2 contains the teamID (I guess it's None type when there is no teamID
// Group 3: CliendID
// Group 4: Mode
// Group 5: Nickname
// Group 6: Text message`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}