// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(([\d]+):)?([\d]+):([\d]+):(.{0,20}): (.*)$").unwrap();
let string = "
// TeamID, ClientID, Mode, PlayerName, Text
//%d:%d:%d:%s: %s - team chat
0:63:1:Günther: hey popelz
// ClientID, Mode, PlayerName, Text
// %d:%d:%s: %s - global chat - previous & current format
63:1:Günther: hey popelz
// this parsing can be split in two regular expressons if needed.
// Group 1 can be ignored
// Group 2 contains the teamID (I guess it's None type when there is no teamID
// Group 3: CliendID
// Group 4: Mode
// Group 5: Nickname
// Group 6: Text message";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}