package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)url(\(((?:[^()]+|(?1))+)\))`)
var str = `
url(https://exemples.com/fonts/lato/lato/lato-regular-webfont.ttf)
src:url(https://exemples.com/fonts/lato/lato-regular-webfont.eot?#iefix)
background:url(https://exemples.com/product/header/img.png)
background:url(/product/header/img.png)
background:url("/product/header/img.png")
background:url('/product/header/img.png')
background:url(/uploads/2019/03/0002-image(thumbnail_product).jpg)
.card-thumb__img1{display:block;width:142px;height:62px;background:url(https://example.com/product01.jpg) center center no-repeat;background-size:contain}@media (max-width:1029px).card-thumb__img2{display:block;z-index:1;background:url(https://example.com/product02.jpg) center center no-repeat #000;
background-image: url(/uploads/2019/03/product01-image(thumbnail_photo).jpg); `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}