import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "url(\\(((?:[^()]+|(?1))+)\\))";
final String string = "\n"
+ "url(https://exemples.com/fonts/lato/lato/lato-regular-webfont.ttf)\n"
+ "src:url(https://exemples.com/fonts/lato/lato-regular-webfont.eot?#iefix)\n"
+ "background:url(https://exemples.com/product/header/img.png)\n"
+ "background:url(/product/header/img.png)\n"
+ "background:url(\"/product/header/img.png\")\n"
+ "background:url('/product/header/img.png')\n"
+ "background:url(/uploads/2019/03/0002-image(thumbnail_product).jpg)\n\n"
+ ".card-thumb__img1{display:block;width:142px;height:62px;background:url(https://example.com/product01.jpg) center center no-repeat;background-size:contain}@media (max-width:1029px).card-thumb__img2{display:block;z-index:1;background:url(https://example.com/product02.jpg) center center no-repeat #000;\n\n"
+ "background-image: url(/uploads/2019/03/product01-image(thumbnail_photo).jpg); ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}