#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "({})\1|[{]\s*?(\S*?|\S*?\(.*?\)|['][^']*?[']|["][^"]*?["]|["][^"]*?["]\.\(.*?\))(?:!(\S+?))?\s*?[}]"
Local $sString = "{0.concat("8a b c d e", 6)}" & @CRLF & _
"s df s sd{"one field name".toFixed(7 , 8)} kjnkj sd asdvs ds sd{0.concat("8a b c d e", 6)} " & @CRLF & _
"" & @CRLF & _
"ascdac{ "one fieldname".toFixed(7 , 8) }" & @CRLF & _
"ascdac{ "onefi eldname" }" & @CRLF & _
"{onefieldname.toFixed(7 , 8)}" & @CRLF & _
"dfgsdg { "onefieldname".toFixed(7 , 8)}" & @CRLF & _
"{onefieldname: "toFixed(7 , 8)"}" & @CRLF & _
"{"onefieldname": "toFixed(7 , 8)"}" & @CRLF & _
"{ "onefiel dname" : "toFixed(7 , 8)"}" & @CRLF & _
"{ "onefiel dname": 8}" & @CRLF & _
"" & @CRLF & _
"{ "onefiel dname" : {"onefi eldname".toFixed(7 , 8)} }" & @CRLF & _
"{ "onefiel dname" : {"onefi eldname".toFixed(7 , 8) }}" & @CRLF & _
"{ "onefiel dname" : {onefieldname.toFixed(7 , 8)} }" & @CRLF & _
"{ "onefiel dname" : { onefieldname.toFixed(7 , 8)} }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")