use strict;
my $str = '{0.concat("8a b c d e", 6)}
s df s sd{"one field name".toFixed(7 , 8)} kjnkj sd asdvs ds sd{0.concat("8a b c d e", 6)}
ascdac{ "one fieldname".toFixed(7 , 8) }
ascdac{ "onefi eldname" }
{onefieldname.toFixed(7 , 8)}
dfgsdg { "onefieldname".toFixed(7 , 8)}
{onefieldname: "toFixed(7 , 8)"}
{"onefieldname": "toFixed(7 , 8)"}
{ "onefiel dname" : "toFixed(7 , 8)"}
{ "onefiel dname": 8}
{ "onefiel dname" : {"onefi eldname".toFixed(7 , 8)} }
{ "onefiel dname" : {"onefi eldname".toFixed(7 , 8) }}
{ "onefiel dname" : {onefieldname.toFixed(7 , 8)} }
{ "onefiel dname" : { onefieldname.toFixed(7 , 8)} }';
my $regex = qr/({})\1|[{]\s*?(\S*?|\S*?\(.*?\)|['][^']*?[']|["][^"]*?["]|["][^"]*?["]\.\(.*?\))(?:!(\S+?))?\s*?[}]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}