# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"({})\1|[{]\s*?(\S*?|\S*?\(.*?\)|['][^']*?[']|[\"][^\"]*?[\"]|[\"][^\"]*?[\"]\.\(.*?\))(?:!(\S+?))?\s*?[}]"
test_str = ("{0.concat(\"8a b c d e\", 6)}\n"
"s df s sd{\"one field name\".toFixed(7 , 8)} kjnkj sd asdvs ds sd{0.concat(\"8a b c d e\", 6)} \n\n"
"ascdac{ \"one fieldname\".toFixed(7 , 8) }\n"
"ascdac{ \"onefi eldname\" }\n"
"{onefieldname.toFixed(7 , 8)}\n"
"dfgsdg { \"onefieldname\".toFixed(7 , 8)}\n"
"{onefieldname: \"toFixed(7 , 8)\"}\n"
"{\"onefieldname\": \"toFixed(7 , 8)\"}\n"
"{ \"onefiel dname\" : \"toFixed(7 , 8)\"}\n"
"{ \"onefiel dname\": 8}\n\n"
"{ \"onefiel dname\" : {\"onefi eldname\".toFixed(7 , 8)} }\n"
"{ \"onefiel dname\" : {\"onefi eldname\".toFixed(7 , 8) }}\n"
"{ \"onefiel dname\" : {onefieldname.toFixed(7 , 8)} }\n"
"{ \"onefiel dname\" : { onefieldname.toFixed(7 , 8)} }")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.