# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?!\d{2}\h*[:-]\h*\d{2}\h*$).*[\r\n]+//gm;t' <<< "01 - 10
This is the first one :1
02:45
This is the second one -2
03-88
This is the third one \"3
04:40
This is the forth one ;4
05 - 50
This is the fifth one .5"