using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\d{2}\h*[:-]\h*\d{2}\h*$).*[\r\n]+";
string substitution = @"";
string input = @"01 - 10
This is the first one :1
02:45
This is the second one -2
03-88
This is the third one ""3
04:40
This is the forth one ;4
05 - 50
This is the fifth one .5";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}