import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)\\bgood(?!.*?good.*?bad).*?\\bbad.*?\\bgood";
final String string = "^(?=.*?\\bmust-have\\b)(?=.*?\\bmandatory\\b)((?!avoid|illegal).)*$\n\n"
+ "good 1 dfd\n"
+ "kjkkjdf\n\n"
+ "good 2 qdqsd\n"
+ "jkfkjg\n"
+ "skdlsk\n\n"
+ "good 3 ggrfdfdfd\n"
+ "dfklfd\n"
+ "dfkl\n"
+ "random length\n"
+ "with multiple lines\n\n"
+ "bad 4 sdjqklj random length\n"
+ "sd4s54 multiple lines\n\n"
+ "good 5 mlp\n"
+ "sldsklds\n\n"
+ "ba";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}