$re = '/(?s)\bgood(?!.*?good.*?bad).*?\bbad.*?\bgood/u';
$str = '^(?=.*?\\bmust-have\\b)(?=.*?\\bmandatory\\b)((?!avoid|illegal).)*$
good 1 dfd
kjkkjdf
good 2 qdqsd
jkfkjg
skdlsk
good 3 ggrfdfdfd
dfklfd
dfkl
random length
with multiple lines
bad 4 sdjqklj random length
sd4s54 multiple lines
good 5 mlp
sldsklds
ba';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);