import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"(?s)\bgood(?!.*?good.*?bad).*?\bbad.*?\bgood"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
^(?=.*?\bmust-have\b)(?=.*?\bmandatory\b)((?!avoid|illegal).)*$
good 1 dfd
kjkkjdf
good 2 qdqsd
jkfkjg
skdlsk
good 3 ggrfdfdfd
dfklfd
dfkl
random length
with multiple lines
bad 4 sdjqklj random length
sd4s54 multiple lines
good 5 mlp
sldsklds
ba
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)