const regex = /(?s)\bgood(?!.*?good.*?bad).*?\bbad.*?\bgood/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)\\bgood(?!.*?good.*?bad).*?\\bbad.*?\\bgood', 'gu')
const str = `^(?=.*?\\bmust-have\\b)(?=.*?\\bmandatory\\b)((?!avoid|illegal).)*\$
good 1 dfd
kjkkjdf
good 2 qdqsd
jkfkjg
skdlsk
good 3 ggrfdfdfd
dfklfd
dfkl
random length
with multiple lines
bad 4 sdjqklj random length
sd4s54 multiple lines
good 5 mlp
sldsklds
ba`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}