package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\+?\d[\s-]?)?[([\s-]{0,2}\d{2,3}[)\]\s-]{0,2}(?:\d{3}[\s-]?\d{4}|\d{2}[\s-]?\d{2}[\s-]?\d{3})`)
var str = `088 11 22 458
+1 88 11 22 458`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}