const regex = /(?:\+?\d[\s-]?)?[([\s-]{0,2}\d{2,3}[)\]\s-]{0,2}(?:\d{3}[\s-]?\d{4}|\d{2}[\s-]?\d{2}[\s-]?\d{3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\+?\\d[\\s-]?)?[([\\s-]{0,2}\\d{2,3}[)\\]\\s-]{0,2}(?:\\d{3}[\\s-]?\\d{4}|\\d{2}[\\s-]?\\d{2}[\\s-]?\\d{3})', 'gm')
const str = `088 11 22 458
+1 88 11 22 458`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}