re = /(?:\+?\d[\s-]?)?[([\s-]{0,2}\d{2,3}[)\]\s-]{0,2}(?:\d{3}[\s-]?\d{4}|\d{2}[\s-]?\d{2}[\s-]?\d{3})/m
str = '088 11 22 458
+1 88 11 22 458'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end