import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\+?\\d[\\s-]?)?[([\\s-]{0,2}\\d{2,3}[)\\]\\s-]{0,2}(?:\\d{3}[\\s-]?\\d{4}|\\d{2}[\\s-]?\\d{2}[\\s-]?\\d{3})";
final String string = "088 11 22 458\n"
+ "+1 88 11 22 458";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}