import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?\\bVores\\s+ref\\.:\\s+\\d+-\\d+\\s+(\\w+).*";
final String string = "ABC This is an example Vores ref.: 23244-2234 LW782837673 Test 2324324";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}