re = /.*?\bVores\s+ref\.:\s+\d+-\d+\s+(\w+).*/m
str = 'ABC This is an example Vores ref.: 23244-2234 LW782837673 Test 2324324'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result