import Foundation
let pattern = #".*?\bVores\s+ref\.:\s+\d+-\d+\s+(\w+).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"ABC This is an example Vores ref.: 23244-2234 LW782837673 Test 2324324"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)