const regex = /.*?\bVores\s+ref\.:\s+\d+-\d+\s+(\w+).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?\\bVores\\s+ref\\.:\\s+\\d+-\\d+\\s+(\\w+).*', 'gm')
const str = `ABC This is an example Vores ref.: 23244-2234 LW782837673 Test 2324324`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);