#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=!\[.*?\]\s*(?:\(.*?\)|\[.*?\]))(?=\[.*?\]\(.*?\))"
Local $sString = "[text](link) ![image][link][text](link)" & @CRLF & _
"" & @CRLF & _
" ![target-image] (link)[text](link)" & @CRLF & _
"" & @CRLF & _
"[[text](url)]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")