$re = '/(?<=!\[.*?\]\s*(?:\(.*?\)|\[.*?\]))(?=\[.*?\]\(.*?\))/';
$str = '[text](link) ![image][link][text](link)
 ![target-image] (link)[text](link)
[[text](url)]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);