using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=!\[.*?\]\s*(?:\(.*?\)|\[.*?\]))(?=\[.*?\]\(.*?\))";
string input = @"[text](link) ![image][link][text](link)
 ![target-image] (link)[text](link)
[[text](url)]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}