re = /(?<=!\[.*?\]\s*(?:\(.*?\)|\[.*?\]))(?=\[.*?\]\(.*?\))/
str = '[text](link) ![image][link][text](link)
 ![target-image] (link)[text](link)
[[text](url)]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end