using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(0{0,2}1+)*0{0,2}$";
string input = @"0000001000011100010101
0011111
01010101
0011111000
011000
0
00
000
1001001001111111
1
1
11
111
1111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}