package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0{0,2}1+)*0{0,2}$`)
var str = `0000001000011100010101
0011111
01010101
0011111000
011000
0
00
000
1001001001111111
1
1
11
111
1111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}