$re = '/^(0{0,2}1+)*0{0,2}$/m';
$str = '0000001000011100010101
0011111
01010101
0011111000
011000
0
00
000
1001001001111111
1
1
11
111
1111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);