// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(0{0,2}1+)*0{0,2}$").unwrap();
let string = "0000001000011100010101
0011111
01010101
0011111000
011000
0
00
000
1001001001111111
1
1
11
111
1111";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}