using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<countryChannel countryCode="".*\/>)";
string input = @"</articleMedia>
<channels>
<countryChannel countryCode=""CountryCode""/> hghgg
</channels>
</article>
<countryChannel countryCode=""CountryCode""/> hghgg
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}