$re = '/(<countryChannel countryCode=".*\/>)/';
$str = '</articleMedia>
<channels>
<countryChannel countryCode="CountryCode"/> hghgg
</channels>
</article>
<countryChannel countryCode="CountryCode"/> hghgg
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);